WordPress 2.7.1 Upgrade Failed on 1and1.com?

bassmadrigal has the solution if WordPress automatic updates don’t work under 1and1.com hosting: WordPress 2.7.1 Upgrade Failed.
All you need to do is add the line:
AddType x-mapp-php5 .php
to your .htaccess. Joy!